Base network stalled

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 10:01 UTC

Monitoring

Base mainnet chain is currently stalled
Posted Aug 05, 2025 - 06:58 UTC