Some integrations are down due to Cloudflare outage.

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:31 UTC

Monitoring

We are currently monitoring the results of a fix related to a Cloudflare outage.
Some integrations are experiencing disruptions due to the ongoing Cloudflare service issues reported here: https://www.cloudflarestatus.com/
Posted Dec 05, 2025 - 09:19 UTC

Identified

Integrations that are down due to Cloudflare outage: Coinbase, Kraken.
Posted Dec 05, 2025 - 09:09 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits).