Global Azure issues impacting Mesh services

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 16:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 11:44 UTC

Investigating

Microsoft Azure is currently experiencing global issues which affect Mesh services. We are currently investigating the problem with Microsoft Azure support
Posted Oct 09, 2025 - 09:57 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits) and Dashboard.