Binance Connectivity Issues

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 17:41 UTC

Investigating

We are currently investigation issues related to Binance connectivity
Posted Jan 22, 2026 - 17:08 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits).