Metamask integration disabled due to Metamask network outage

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Jun 13, 2026 - 21:01 UTC

Monitoring

Metamask has reported an outage causing network connectivity issues - https://x.com/MetaMaskSupport/status/2065866721026572666
We have currently disabled the integration and are monitoring closely.
Posted Jun 13, 2026 - 19:08 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits).