Binance Transfer Issues - Service Degradation

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 09:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 08:54 UTC

Update

A fix has been deployed to resolve the issue affecting Binance transfers. We are now monitoring the system to ensure stability and that the issue has been fully resolved. We will provide a final update once monitoring is complete.
Posted Apr 02, 2026 - 08:51 UTC

Identified

We have identified the cause of the issue affecting Binance transfers. Our engineering team is currently implementing a fix and will deploy it shortly. We will continue to monitor the situation and provide updates as we work toward resolution.
Posted Apr 02, 2026 - 08:14 UTC

Investigating

We're currently experiencing issues with Binance transfers. Some transfer requests may fail or experience delays. Our team is actively investigating and working on a resolution.
Posted Apr 02, 2026 - 08:07 UTC
This incident affected: Products (Mesh Pay, Mesh Deposits).