Webhook functionality is currently unavailable.

Incident Report for Mesh Connect Status Page

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 17:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 11:31 UTC

Identified

Webhook functionality is currently unavailable, meaning any transfer status updates relying on Mesh webhooks may be inaccurate.
Issue is identified, fix is in progress.
Posted Dec 04, 2025 - 11:13 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits).