SSL Certificate Issues

Incident Report for Mesh Connect Status Page

Resolved

The SSL certificate issue has been resolved. Services are back to normal.
Posted Sep 14, 2024 - 21:07 UTC

Identified

We have identified the cause of the issue and are implementing a fix.
Posted Sep 14, 2024 - 20:56 UTC

Investigating

We are currently investigating an issue with an expired SSL certificate.
Posted Sep 14, 2024 - 19:13 UTC
This incident affected: API and Dashboard.