Third-Party Outage: Cloudfront Mesh Services (AWS)

Incident Report for Mesh Connect Status Page

Postmortem

On Feb 10, 2026, we observed that AWS CloudFront was down/degraded, which caused degraded performance for some Mesh services, including Coinbase Onramp transactions. During this time, some users may have experienced latency or failed requests. We monitored the upstream recovery and confirmed services returned to normal once AWS CloudFront recovered.

Posted Feb 10, 2026 - 22:09 UTC

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 22:03 UTC

Update

We are continuing to investigate this issue.
Posted Feb 10, 2026 - 22:03 UTC

Investigating

We’re investigating reports of a CloudFront outage that may be impacting Mesh services hosted on AWS. Some users may experience elevated errors or degraded performance. We’ll provide updates as we learn more.
Posted Feb 10, 2026 - 21:48 UTC