All of our services are back online. We are actively monitoring them for any further disruptions that may come from the issues faced by our cloud provider. Some minor UI issues may persist while our provider recovers. We appreciate your patience in this matter.
Posted Oct 29, 2025 - 20:50 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 16:42 UTC
Update
Access to some of our services has been restored, and we are seeing signs of recovery following the Azure service disruption.
Our team is actively working to mitigate the remaining impact and ensure full service stability. Several dependent systems, including APIs and backend functions, may still experience intermittent issues during this recovery phase.
We are currently experiencing degraded performance across several integrations due to an ongoing Azure service disruption. This issue is impacting multiple dependent services, including APIs and backend functions.
Posted Oct 29, 2025 - 16:05 UTC
This incident affected: Products (Mesh Pay, Mesh Verify, Mesh Deposits) and Dashboard.